
<!DOCTYPE html>
<!--==================================================
==================START: HEADER====================-->
<html lang="en">
	<head>
		
		<!--
macro: mainmeta (MCD 201610140350)
current date: 20200423235329
template: 
currentrequest: /apps/pbcs.dll/article?avis=NC&date=20200423&category=OPINION&lopenr=200429580&Ref=AR
currentrequestunmodified: /opinion/20200423/thursdays-letters-elusive-peace
@templatetype: /apps/pbcs.dll/article?avis=NC&date=20200423&category=OPINION&lopenr=200429580&Ref=AR
@pagetype: article
app version: 2.0.455
-->
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta property="og:site_name" content="Topsail Advertiser" />
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" /> 
<meta name="msvalidate.01" content="7E15F9269E2CE66F2A488ABB04B5015E" />

		<title> Thursday&#8217;s letters: Elusive peace - Opinion - Topsail Advertiser - Jacksonville, NC</title>
<!-- Meta Tags - Global Article6 guid: DB8DC9EE-BAB9-4BEF-BF5E-312C5E0F11F8-->
<meta name="description" content="Elusive peaceTo the editor: The coronavirus has changed the way millions of we humans are living and has taken a heavy death toll along the way. We are saddened and mourn those who have passed.However, having just recognized the 50th anniversary of Earth Day, we should reflect on the more than 15 million other species with whom we share the planet. Often we are caught up with our own welfare at the expense of so many others.While great environmental gains have been made since the early 1970s, e." />
<meta property="bt:pubDate" content="20200423T03:01:19Z">
<meta property="bt:modDate" content="20200423T03:01:00Z">
<meta property="bt:keywords" content="Commuters">
<meta property="bt:author" content="">
<meta name="twitter:title" content="Thursday's letters: Elusive peace">
<meta name="twitter:description" content="Elusive peaceTo the editor: The coronavirus has changed the way millions of we humans are living and has taken a heavy death toll along the way. We are saddened and mourn those who have passed.However, having just recognized the 50th anniversary of Earth Day, we should reflect on the more than 15 million other species with whom we share the planet. Often we are caught up with our own welfare at the expense of so many others.While great environmental gains have been made since the early 1970s, e.">
<meta property="og:title" content="Thursday's letters: Elusive peace"/>
<meta property="og:description" content="Elusive peaceTo the editor: The coronavirus has changed the way millions of we humans are living and has taken a heavy death toll along the way. We are" />
	<meta name="twitter:card" content="summary">
		<meta name="twitter:image" content="https://www.topsailadvertiser.com/Global/images/head/nameplate/topsailadvertiser_logo.png">
		<meta property="og:image" content="https://www.topsailadvertiser.com/Global/images/head/nameplate/topsailadvertiser_logo.png">
	<meta property="vf:unique_id" content="siteNC-pub2874-DB8DC9EE-BAB9-4BEF-BF5E-312C5E0F11F8">
	<link rel="canonical" href="https://www.topsailadvertiser.com/opinion/20200423/thursdays-letters-elusive-peace"/>
<link rel="amphtml" href="https://www.topsailadvertiser.com/opinion/20200423/thursdays-letters-elusive-peace?template=ampart">
<script type="application/ld+json">
  {
    "@context": "http://schema.org",
    "@type": "NewsArticle",
    "mainEntityOfPage": {
		"@type": "WebPage",
		"@id": "https://www.topsailadvertiser.com/opinion/20200423/thursdays-letters-elusive-peace"
	},
    "headline": "Thursday&#8217;s letters: Elusive peace",
    "url": "https://www.topsailadvertiser.com/article/20200423/OPINION/200429580",
    "thumbnailUrl": "https://www.topsailadvertiser.com/apps/pbcsi.dll/bilde?Site=NC&Date=20200423&Category=OPINION&ArtNo=200429580&Ref=AR",
    "dateCreated": "20200423T08:01:19Z",
    "datePublished": "20200423T08:01:19Z",
    "dateModified": "20200423T08:01:00Z",
    "publisher": {
       "@type": "Organization",
       "name": "Topsail Advertiser",
       "logo": {
         "@type": "ImageObject",
         "url": "https://www.topsailadvertiser.com/Global/images/head/nameplate/topsailadvertiser_logo.png"
       }
    },
    "articleSection": "Opinion",
    "keywords": ["Opinion","Letters","NC_Hendersonville - blueridgenow.com","Commuters"],
    "isAccessibleForFree": "False",
	"hasPart":
	{
		"@type": "WebPageElement",
		"isAccessibleForFree": "False",
		"cssSelector" : ".paywall-is-accessible-for-free"
	},
	"isPartOf": {
    "@type": ["CreativeWork", "Product"],
    "name" : "Topsail Advertiser",
    "productID": "topsailadvertiser.com:standard"
	}
  }
</script>
<meta property="fb:app_id" content="1401884143360972"/>
<meta property="og:type" content="article"/>
<meta property="article:opinion" content="true"/>
<!-- Taboola Script needs to be in the article head -->
<!-- Rest of Taboola widget is in /macros/includes/article/taboola.pbo -->
<script type="text/javascript">
		window._taboola = window._taboola || [];
		_taboola.push({article:'auto'});
		!function (e, f, u) {
		e.async = 1;
		e.src = u;
		f.parentNode.insertBefore(e, f);
		}(document.createElement('script'), document.getElementsByTagName('script')[0], 'http://cdn.taboola.com/libtrc/nytrng-network/loader.js');
</script>

		<script type="text/javascript">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</script>
				        <link rel="stylesheet" type="text/css" href="https://fonts.googleapis.com/css?family=Oswald:300,400,700|Roboto+Condensed:400,400i,700,700i|Crimson+Text:400,400i,700,700i|Rubik:400,500,700,900" crossorigin="anonymous" />
        <link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.min.css" type="text/css" crossorigin="anonymous" />
        <link rel="stylesheet" href="//cdn.gatehousemedia.com/assets/css/2.0.455/default.min.css" type="text/css" crossorigin="anonymous" />
		<style type="text/css">
	#toprail-microbar{
		z-index:1000;
	}
	/*legacy-header*/
	.legacy-header #baseLeaderboard {
		margin-top:25px;
	}
	#header-content div#slidingBillboard.ad.text-center {
		padding: 0;
		margin: 0;
	}
	#article > div > section.article-v2-left > div.ad-container { clear: both; }
	@media only screen and (max-width: 768px) {
		#buckets > div.article-extra > h4.chatter-title {
		    font-size: 2em;
		}
	}
	section.article-v2-right > div.article-body.p402_premium > div.vendor-logo.byline-item > img{
		max-width: 150px;
	}
	#apoc-breaking-wrapper{position: relative;z-index:100;}
	article.summary .inner .related li {max-height:fit-content!important;}
    /*==== ARTICLE ======*/
    .ad-300x250{
	    height: auto !important;
    }
    .pgs-dpg-flex, .pgs-dpg-card, div.pgs-dpg-card > iframe, div.pgs-dpg-flex > iframe{
		max-width: 350px;
		max-height: 460px;
		overflow: hidden;
	}
		/*==== for taboola ======*/
    	.article-newsletter-signup,#dialog-message{
	    	display: none !important;;
    	}
    	@media only screen and (min-width: 768px) {
			#interstitial{display:none;}
		}
    	/*story strip article ad*/
    	/* cssUpdates branch*/
    	div.gh-slider-storyStrip > div.adInject > div > iframe {
			max-height:90px;
		}
    	/* cssUpdates branch*/
    	.gh-slider-caption h3:not(.is-truncated):not([style="word-wrap: break-word;"]){
			-webkit-line-clamp: 4;
		    text-overflow: ellipsis;
    	}
    	.article-meta-day,a:visited  {
			font-family: "Roboto Condensed","Helvetica Neue","Helvetica","Roboto","Arial",sans-serif;
			font-size: 18.662px;
			font-weight: bold;
			color: #698096;
			display: block;
			font-kerning: normal;
			text-rendering: optimizeLegibility;
			margin-bottom: 10px;
			text-decoration: none;
		}
		#flipp-promo {
		    max-width: 300px;
		    margin: 0 auto;
		    max-height: 250px;
		 }
    	/* Viafoura email & password fields in registration/signup screens */
	 	.viafoura .vf-forgot-pw-link, .viafoura .vf-account-form {
	 		display: none;
	 	}
    	/*  TERMS OF SERVICE LINK - under viafoura comments submit button */
    	.vf-terms-of-service { margin-left: 12px;}
		/* TOUT MID ARTICLE PLAYER */
		.tout-mid-article { display:block; margin-right:2.35%; width:100%; }
	/* MOBILE article story stack */
    .gh-article-storyStack {
        background-color: #f3f3f3;
        display: inline-block;
        width: 100%;
        height: 150vw;
    }
    .gh-stacked {
        display: inline-block;
        padding: 2vw 2vw 4vw 2vw;
        margin: 0 0 3vw 0;
        height: 25vw;
        width: 100%;
    }
    .gh-stacked figure {
        width: 20vw;
        height: 20vw;
        display: inline-block;
        float: left;
        /* margin: 0 3vw 0 0; */
    }
    .gh-stacked h3 {
        width: calc(100% - 4.8em - 1.618em);
	    font-size: 1.25em;
	    line-height: 1.3em;
	    float: left;
	    display: inline;
    }
    .gh-article-storyStack .slick-slide .image{min-height:80px !important;}
    .gh-article-storyStack .slick-slide a{display:block;height:100%;width:100%;border-bottom: 1px solid #454545;margin-bottom:5px;}
</style>
		<style>
@media screen and (min-width: 768px){
	figure > a > div.teaser > span.native-thumbnail-dateline  {color:lightskyblue;}
}
@media screen and (max-width: 767px){
	figure > a > div.teaser > span.native-thumbnail-dateline  {color:#039be5;}
}
</style>
				<script type="text/javascript">
			window.supportsLocalStorage = false;
			try {
				window.supportsLocalStorage = !!window.localStorage
				    && typeof localStorage.getItem === 'function'
				    && typeof localStorage.setItem === 'function'
				    && typeof localStorage.removeItem === 'function';
			} catch(e) {
				console.error('localStorage error', e);
			}
			if(window.supportsLocalStorage === false) {
				console.warn('localStorage is not supported on this browser.');
			}
		</script>
		<script src="https://cdnjs.cloudflare.com/ajax/libs/jquery/2.1.4/jquery.min.js?20160411-3" crossorigin="anonymous"></script>
		<!-- Google Tag Manager -->
<script>
  //PAGE DATA
  __gh__coreData.pageData.type2 = "Article";
  __gh__coreData.pageData.error = __gh__coreData.pageData.type2 == "404" ? "404" : undefined;
  //USER
  __gh__coreData.user = {id:undefined,accessLevel:undefined};
  // Get clientside pieces from LocalStorage object
  if (window.supportsLocalStorage === true && typeof localStorage['_vxData'] != "undefined"){
    var _vxDataObj = JSON.parse(localStorage['_vxData']);
    __gh__coreData.user				= _vxDataObj;
  }
  //define main dataLayer for object for GTM
  window.dataLayer 	= window.dataLayer || [];
  dataLayer.push(__gh__coreData);
var __gh__gtm = {
	id:'GTM-WF5MZJ9'
};
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer',__gh__gtm.id);
</script>
<!-- End Google Tag Manager -->
		<script async='async' src='//cdn.adsafeprotected.com/iasPET.1.js'></script>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u, i) {
    if (!document.getElementById(i)){
      e.async = 1;
      e.src = u;
      e.id = i;
      f.parentNode.insertBefore(e, f);
    }
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  '//cdn.taboola.com/libtrc/gannett-network/loader.js',
  'tb_loader_script');
  if(window.performance && typeof window.performance.mark == 'function')
    {window.performance.mark('tbl_ic');}
</script>
		<!--[if lte IE 9]>
			<script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.min.js"></script>
			<script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv-printshiv.min.js"></script>
			<script src="https://cdnjs.cloudflare.com/ajax/libs/respond.js/1.4.2/respond.min.js"></script>
		<![endif]-->
		<!-- Begin comScore Tag -->
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "9289482" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "https://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="https://b.scorecardresearch.com/p?c1=2&c2=9289482&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

		
	</head>
<!--================================================
==================END: HEADER====================-->

	<body class="__PAGETYPE__">
		          
	<div id="fb-root"></div>
	
		<a href="#" id="backToTop"><i class="fa fa-chevron-up"></i></a>
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-WF5MZJ9"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

		<div id="wrapper-main">
			
					<header id="header-main" class="header header-expanded no-gutter static clearfix">
			<div id="toprail">
	<div class="inner clearfix">
		<a id="button-nav-toggle"
			title="Navigation menu">
			<span class="hidden-sm hidden-xs">Sections</span>
			<i class="fa fa-fw fa-bars"></i>
		</a>
			<ul id="toprail-nav-left" class="list-inline"><li><a href="https://www.topsailadvertiser.com/news" target="_top">News</a></li><li><a href="https://www.topsailadvertiser.com/opinion" target="_top">Opinion</a></li><li><a href="https://www.topsailadvertiser.com/entertainment" target="_top">Entertainment</a></li><li><a href="https://www.topsailadvertiser.com/jobs" target="_top">Jobs</a></li><li><a href="https://www.topsailadvertiser.com/section/cars" target="_top">Cars</a></li><li><a href="http://www.encclassifieds.com/" target="_top">Classifieds</a></li></ul>
		<ul id="toprail-nav-right" class="list-inline">
				<!-- JMETA MENU: SUBSCRIBE: count($items) = 0 -->
			<li id="toprail-search" class="hidden-sm hidden-xs">
											<div id="toprail-search-form">
								<form class="search-bar input-group" role="search" name="siteSearchForm" method="get" action="/search">
									<input class="search-input" name="searchText" placeholder="Search this site" type="search">
									<button type="submit" class="fa fa-fw fa-lg fa-search"></button>
								</form>
							</div>
							<i class="fa fa-fw fa-lg fa-search"></i>
			</li>
				<li id="toprail-weather" class="hidden-xs" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.topsailadvertiser.com/section/?template=ajaxWeather" data-gh-fetch-html-dom="#toprail-weather"></li>
		</ul>
		<div id="toprail-microbar">
			<div class="ad text-center">
				<div class="ad ad-topbanner text-center" data-gh-lazy-ad-bucket-targeting='{"ad-type":"standard","slot":"Base Micro Bar","sov":"base ROS","allow_adx":"false"}' id="topBarSponsor" data-dimensions="[88,31]"></div>
			</div>
		</div>
	</div>
</div>
						<div id="header-main-nameplate">
				<div id="header-main-left">
					<div id="header-main-logo">
						<a href="https://www.topsailadvertiser.com">
							<img class="mainheadnameplate" src="https://www.topsailadvertiser.com/Global/images/head/nameplate/topsailadvertiser_logo.png"  alt="Topsail Advertiser" />
						</a>
					</div>
				</div>
				<div id="header-main-center">
					<!-- JMETA MENU: SUBSCRIBE: count($items) = 0 -->
				</div>
				<div id="header-main-right" class="hidden-xs">
					<div id="header-main-promo" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.topsailadvertiser.com/section/?template=ajaxPromoWiz7" data-gh-fetch-html-dom="#header-main-promo"></div>
				</div>
			</div>
		</header>


<!--==================================================
==========================START: CONTENT===========-->
			<div id="content" class="clearfix">
				

<div class="alert"></div>
<div id="apoc-breaking-wrapper" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.topsailadvertiser.com/section/breaking_ajax?template=breaking_ajax2" data-gh-fetch-html-dom="#apoc-breaking-wrapper"></div>
<div data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://cdn.gatehousemedia.com/gh-sites/global/breaking/breaking-special.html"></div>

				<div class="ad ad-billboard text-center" id='ad-base-leaderboard-article'>
	<div id="baseLeaderboard" data-size-mapping="baseLeaderBillboardArticle"></div>
	<div data-gh-object-loaded="false" 
		data-gh-object-offset="0" 
			data-gh-object='{"method":"__gh__webApp.utilities.adsRefresh.init","data":{"id":"baseLeaderboard-adRefresh","orgId":"baseLeaderboard","loadNow":"false","container":"ad-base-leaderboard-article"}}'
				class="ad-refresh" 
					data-gh-lazy-ad-bucket-targeting='{"ad-type":"standard","slot":"Base Leaderboard","sov":"base ROS","refresh":"true"}' 
						data-dimensions="[[970,90],[970,250],[728,90]]" 
							id="baseLeaderboard-adRefresh" 
							 data-size-mapping="baseLeaderBillboardArticle" 
								 data-gh-object-parent-height="true"></div>
</div>

				<div id="wrapper" class="clearfix">
					<div id="buckets">
	<article class="full article-v2 loading" data-updated="20200423030119">
	<div class="inner">
		<h1 class="headline">Thursday&#8217;s letters: Elusive peace</h1>
		<section class="article-v2-left">&nbsp;</section>
		<section class="article-v2-right">
			<div class="article-body">
				<span class="byline-item">
				</span>
				<div class="article-meta">
					<div class="inner">
						<div class="article-meta-main">
							<h3 class="article-meta-day">Thursday</h3>
							<span class="article-meta-date">Apr&nbsp;23,&nbsp;2020&nbsp;at&nbsp;3:01&nbsp;AM</span>
							<span class="article-meta-updated"></span>
						</div>
					</div>
				</div>
				<br><br>
				<div class="inner">
					<p class="article-summary"></p>
					<p><p>Elusive peace</p><br><p>To the editor: The coronavirus has changed the way millions of we humans are living and has taken a heavy death toll along the way. We are saddened and mourn those who have passed.</p><br><p>However, having just recognized the 50th anniversary of Earth Day, we should reflect on the more than 15 million other species with whom we share the planet. Often we are caught up with our own welfare at the expense of so many others.</p><br><p>While great environmental gains have been made since the early 1970s, e.g. Clean Air Act, Clean Water Act, Endangered Species Act, the current administration is trying to eliminate many of these protections. We are currently witnessing Earth&#8217;s sixth great extinction, with more than 30% declines in global frog species and North American migratory bird populations.</p><br><p>To quote Dr. Albert Schweitzer, &#8220;Until he extends his circle of compassion to include all living things, man will not himself find peace.&#8221; Peace continues to be elusive.</p><br><p>R. Michael Erwin, Hendersonville</p><br><p>Sweet protection</p><br><p>To the editor: Amid the COVID-19 virus pandemic, it&#8217;s essential that everyone wear masks and other personal protective equipment whenever they are outside their home.</p><br><p>Paraphrasing Jackie DeShannon&#8217;s song: What the world needs now is protection, sweet protection. It's the only thing that there's just too little of. What the world needs now is protection, sweet protection. No, not just for some but for everyone.</p><br><p>Arising out of COVID-19 is the rising number of lawsuits being brought against businesses. Social distancing is not enough to prevent the spread of COVID-19. To help protect your business from these suits, it&#8217;s not enough to go around your stores disinfecting everything and/or even providing curbside pickup.</p><br><p>If customers are coming into your store, you need to require them to wear masks and gloves at a minimum. You also need to require All employees to do the same while they are working or on break.</p><br><p>No mask, no gloves = no entry.</p><br><p>Phil Rasmussen, Hendersonville</p><br><p>More obnoxious</p><br><p>To the editor: I have been watching Donald Trump&#8217;s press conferences, and his lies, obfuscations and defensiveness are becoming more obnoxious as COVID-19 becomes worse. Among other reasons, he is using these road shows to justify eliminating oversight of the massive $2 trillion aid package that were passed by Congress.</p><br><p>The chairman of the oversight committee charged with overseeing the distribution of the massive $500 billion slush fund to be given to large corporations for keeping their workers on the payroll through the pandemic rather than losing them permanently was removed. We were warned of this eventuality when Trump signed the bill; he said he did not intend to obey the part of the bill that required this oversight, stating he would perform the oversight.</p><br><p>Gee, what could go wrong? The most corrupt president in the history of our country in charge of literally a fortune to be distributed by him with only subordinates on the committee.</p><br><p>He recently removed a longtime inspector general who issued a report showing a survey of more than 300 hospital executives who overwhelmingly reported shortages of PPE, hospital beds and ventilators because the report contradicted his rosy lies that there are no shortages and the IG was appointed by President Bill Clinton.</p><br><p>Al Weis, Hendersonville</p><br><p>Unsung heroes</p><br><p>To the editor: While most of us are hunkered down in our homes due to COVID-19, there are many workers in our community, most of them unknown to us, who are today&#8217;s heroes. They may never be mentioned in the news, as they tend to be in the background of our lives, but they, along with medical personnel and hospital workers, are also heroes worthy of recognition.</p><br><p>Think about the men and women such as the postal workers, newspaper home delivery people, truck drivers, UPS and FedEx delivery drivers, clerks at local gas stations, recycling and garbage collection workers, the men and women doing checkout or restocking in grocery stores, the police, ambulance drivers and firefighters, and the list goes on and on.</p><br><p>These heroes have selflessly placed themselves at risk of exposure to COVID-19 virus to serve those of us who are staying safely at home.</p><br><p>The next chance you get to interact with one of these heroes, please take a minute to simply say, &#8220;Thank you for what you&#8217;re doing for me, my family and our community.&#8221; It&#8217;ll mean a lot.</p><br><p>Ron Kauffman, STAND T.A.L.L., Hendersonville</p><br><p>Shortsighted</p><br><p>To the editor: The Strategic National Stockpile of N95 respirators, surgical masks and other medical supplies are nearly out. According to House Oversight Chairwoman Carolyn Maloney, &#8220;The president failed to bring in FEMA early on, failed to name a national commander for this crisis, and failed to fully utilize the authorities Congress gave him under the Defense Production Act to procure and manage the distribution of critical supplies.&#8221;</p><br><p>Instead, President Donald Trump played down the virus the first two months, calling it a &#8220;hoax&#8221; that was perpetrated by the Democrats and the media, and predicting as late as Feb. 26 that the number of U.S. cases would soon drop to zero. Now health care workers on the front lines are facing possible lack of protection to carry out their work.</p><br><p>I hope that by election time this November, Trump supporters will see that it is dangerous to our country and to the world to have such a shortsighted and self-serving person as our president and commander in chief.</p><br><p>Connie Knight, Hendersonville</p><br><p>Incompetent</p><br><p>To the editor: Before Donald Trump was elected president, I warned everyone in these pages that he wasn&#8217;t a manager. I stated that he was just this side of a river boat gambler. A &#8220;slam-bam, thank you, Sam&#8221; dealer without skills for day-to-day follow-through.</p><br><p>Sadly, all of this has come to pass. In these extreme times, he ignored advice by science that he should act. That&#8217;s when he stated that it's just like a mild flu that will be gone by April. He rejected immediate action that could have saved lives.</p><br><p>Our nation is down on its knees by his lack of leadership. Our economy is weakened, unemployment is skyrocketing, and companies are hemorrhaging.</p><br><p>While the world around us is collapsing, his thin-skinned staff took it upon themselves to add salt to the wounds and destroy the morale of one of our major weapons, the USS Theodore Roosevelt. It&#8217;s dockside in Guam without a skipper.</p><br><p>Does anyone with Trump have any idea how the 4,000 officers and sailors are coping? Good old bone spurs in chief is at sea himself.</p><br><p>Is he a &#8220;deal maker&#8221;? Tell us about North Korea, Iran, India, China or the Palestine-Israel peace plan. Is everything in good shape here?</p><br><p>Trump is incompetent and can't hold a real job.</p><br><p>Arthur Swygard, Hendersonville</p></p>
				</div>
			</div>
		</section>
	</div>
</article>
</div>

				</div><!-- /wrapper -->
			</div><!-- /content -->

			<div id="push-main" class="clearfix"></div>
		</div><!-- /wrapper-main -->
<!--==================================================
====================END: CONTENT===================-->
				<footer id="footer-main" class="clearfix">
			<div class="inner container">
				<div id="footer-main-info" data-gh-accordion-loaded="false" data-gh-accordion-panel-dom="#footer-main-info .footer-col ul" data-gh-accordion-toggle-dom="#footer-main-info &gt; .footer-col &gt; h4" data-gh-accordion-open-at="480"></div><!-- /footer-main-info -->
			</div><!-- /inner++++/apps/pbcs.dll/article?avis=NC&date=20200423&category=OPINION&lopenr=200429580&Ref=AR -->
			<div id="footer-main-copyright">
					<p id="footer-copyrightInfo">&copy; Gannett Co., Inc. 2020. All rights reserved.</p>
	<p>Original content available for non-commercial use under a Creative Commons license, except where noted.
	<br />Topsail Advertiser  ~ 724 Bell Fork Road, Jacksonville, NC 28540<span class="gdpr hide"> ~ <a id="ot-sdk-btn" class="ot-sdk-show-settings" href="javascript:void(0);">Do Not Sell My Personal Information</a> ~ <a href="https://www.topsailadvertiser.com/section/cookie-policy" target="_blank">Cookie Policy</a></span><span class="gdpr-disabled hide"> ~ <a href="https://www.gannett.com/cookie-policy/" target="_blank">Do Not Sell My Personal Information</a></span> ~ <a href="http://www.gannett.com/privacy-statement/" target="_blank">Privacy Policy</a> ~ <a href="http://www.gannett.com/terms-of-use/" target="_blank">Terms Of Service</a> ~ <a href="https://www.gannett.com/ccpa/" target="_blank">Your California Privacy Rights / Privacy Policy</a></p>
	<p><a href="/ownership">Gannett | USA TODAY NETWORK</a></p>
			</div>
		</footer><!-- /footer -->
				<nav id="drawer" role="navigation">
			<br>
			<div id="drawer-search" class="hidden-md hidden-lg">
				<form class="search-bar input-group" role="search" name="siteSearchForm" method="get" action="/search">
					<div class="input-group-btn">
						<button type="button"
							class="btn btn-default dropdown-toggle"
							data-toggle="dropdown"
							aria-haspopup="true"
							aria-expanded="false">
							<span class="caret"></span>
						</button>
						<ul class="dropdown-menu" id="searchparam_dd">
							<li data-type="site" class="selected">Site</li>
							<li data-type="archive">Archive</li>
						</ul>
					</div>
					<input class="search-input" name="searchText" placeholder="Search Site" type="search">
					<button type="submit" class="fa fa-fw fa-lg fa-search"></button>
				</form>
			</div>
			<hr class="hidden-md hidden-lg">
			<div class="inner">
				<div id="wrapper-drawer">
						<ul 
					 class="nav" 
					 data-gh-accordion-loaded="false" 
					 data-gh-accordion-panel-dom="#drawer-nav-sections .subnav" 
					 data-gh-accordion-toggle-dom="#drawer-nav-sections &gt; li &gt; a" 
					 id="drawer-nav-sections"
				   ><li><a href="https://www.topsailadvertiser.com" target="_top">Home</a></li><li><a href="https://www.topsailadvertiser.com/news"><span class="nav-category">News</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"19858"><a href="https://www.topsailadvertiser.com/topics/keyword" target="_top">Area Happenings</a></li><li id="navLink-TEST-"19859"><a href="http://digital.olivesoftware.com/olive/ode/ENCSpecialSections/default.aspx?href=ENCss/2014/03/05" target="_top">Discover Topsail</a></li><li id="navLink-TEST-"33832"><a href="http://elections.gatehousemedia.com/topsailadvertiser/todaystopics/" target="_blank">Election 2106</a></li></ul></li><li><a href="https://www.topsailadvertiser.com/opinion" target="_top">Opinion</a></li><li><a href="https://www.topsailadvertiser.com/business-news" target="_top">Business</a></li></ul>
	<ul class="drawer-nav-secondary nav"><header>More</header><li><a href="https://www.topsailadvertiser.com/lottery" target="_top">Lottery Results</a></li><li><a href="https://www.topsailadvertiser.com/videos" target="_top">Videos</a></li><li><a href="https://www.topsailadvertiser.com/contests" target="_top">Contests</a></li><li><a href="https://www.topsailadvertiser.com/ara" target="_top">Branded Content</a></li><li><a href="https://www.topsailadvertiser.com/submit" target="_top">Submit Your News</a></li><li><a href="https://www.topsailadvertiser.com/section/promoted//?prx_adpz=2304" target="_top">From Our Advertisers</a></li><li><a href="https://www.topsailadvertiser.com/southern-kitchen" target="_top">Southern Kitchen</a></li></ul>
	<!-- JMETA MENU: SECONDARY NAVIGATION: !count($items) -->
	<ul class="drawer-nav-secondary nav"><header>Market Place</header><li><a href="http://www.encclassifieds.com" target="_top">Classifieds</a></li><li><a href="http://m.topsailadvertiser.com/section/cars" target="_top">Cars</a></li><li><a href="http://www.encjobfinder.com" target="_top">Jobs</a></li><li><a href="http://topsailadvertiser.thrivehive.com/" target="_blank">Digital Marketing Services</a></li></ul>
<footer id="footer-drawer">
	<hr>
	<ul class="drawer-nav-secondary nav">
		<li>
			<a href="mailto:topsail@jdnews.com">Feedback</a>
		</li>
		<li>
			<a href="https://www.topsailadvertiser.com/ownership">Ownership</a>
		</li>
		<li>
			<a href="https://www.gannett.com/terms-of-use/" target="_blank">Terms of Use</a>
		</li>
		<li>
			<a href="https://www.gannett.com/privacy-statement/" target="_blank">Privacy Policy</a>
		</li>
		<li>
			<a href="https://www.gannett.com/brands/" target="_blank">Gannett Publications</a>
		</li>
	</ul>
</footer>
				</div>
				<footer id="footer-drawer">
					<div id="drawer-weather" class="visible-xs-block text-center" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.topsailadvertiser.com/section/?template=ajaxWeather" data-gh-fetch-html-dom="#drawer-weather">
					</div>
					<ul class="social list-inline">
						<li>
							<a	href="https://www.topsailadvertiser.com/section/feed"
								target="_blank"
								title="Topsail Advertiser RSS Feed">
								<i class="fa fa-fw fa-rss"></i>
							</a>
						</li>
						<li>
							<a	href="https://www.topsailadvertiser.com/contact"
								title="Contact Topsail Advertiser">
								<i class="fa fa-fw fa-envelope"></i>
							</a>
						</li>
					</ul>
					<!-- <span id="drawer-copyrightInfo">&copy; 2015 __SITENAME__</span> -->
				</footer>
			</div><!-- /.inner -->
		</nav>
		<div id="drawer-fade-screen"></div>

				<script type="text/javascript">
		__gh__coreData.pageData.pageType2 = "Article";
		</script>
		<script src="//cdn.gatehousemedia.com/gh-sites/global/ads/ads.js" crossorigin="anonymous"></script>
		<script src="//cdn.gatehousemedia.com/assets/2.0.455/app.min.js" crossorigin="anonymous"></script>
		<script>
window.googletag = window.googletag || {};
window.googletag.cmd = window.googletag.cmd || [];
</script>
<script>
  window.confiant = window.confiant || {};
  window.confiant.enable_integrations = ['gpt'];
  var pbjs = pbjs || {};
  pbjs.que = pbjs.que || [];
</script>
<script async="" src="https://confiant-integrations.global.ssl.fastly.net/JYokDAn2beiT-wdiDnha5IuKJm0/gpt_and_prebid/config.js"></script>
<script>
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore( A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");</script>
<script async src="https://js-sec.indexww.com/ht/p/183763-221412910371223.js"></script>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({flush: true});
</script>
		<script>
		function __gh__init() {
		var delay = 100;
			var maxDelay = 45000;
			var __gh__asyncInit = setInterval(function() {
			    if (typeof $ !== 'undefined' && typeof __gh__webApp !== 'undefined') {
			    	try {
						__gh__webApp.init();
						__gh__webApp.articlePage.init();
					} catch (e) {
						console.error('webapp failed to initialize', e);
					}
			        clearInterval(__gh__asyncInit);
			    } else if (delay > maxDelay) {
			    	console.error('webapp init timed out');
			        clearInterval(__gh__asyncInit);
			    }
			    delay *= 2;
			}, delay);
		}
		</script>
		<script>__gh__init();</script>
			<script async src="//cdnjs.cloudflare.com/ajax/libs/twitter-bootstrap/3.3.5/js/bootstrap.min.js?201604-1" crossorigin="anonymous"></script>

		
<!--currenttimestamp: 2020-04-23&nbsp;23:53:29-->
	</body>
</html>
